Category: Networking

What is Computer Network

What is Computer Network

What is Computer Network:-Computer network is a collection of  computers that are interlinked to each other with any communicating media such as network cables , routers etc so as to share resources among each other.What is Computer Networkthe resources shared can be in any format whether it may be images ,audio files, images etc. the computers are termed as a nodes in network. The computer network can provides us such usages

  1. Allows us to share files across different systems
  2. Allows multiple users to use same common hardware
  3. Allow more easy and efficient way of data communication
  4. Allows fast and safe way to communicate irrespective of  distances
  5. Allows sharing of software among different systems

There are different types of networks such as :-

  • Local Area Networks (LAN)
  • Wide Area Networks (WAN)
  • Metropolitan Area Networks (MAN)
  • Campus Area Networks (CAN)
  • Personal Area Networks (PAN)

These network uses either wired network connections or wireless network connections.In wired network connection optical fibre , straight cable , cross cable etc are being used as communication medium and in wireless network infra red signals , radio waves , satellite etc are being used .

Dynamic NAT Configuration

Dynamic NAT Configuration

In this topic we will learn Dynamic NAT Configuration. NAT stands for network address translation. in Dynamic NAT number of internal  IP are converted into into External IP network . internal private IP can be converted to  any external public IP. This is also termed as many to many translation.lets start our configuration.

Step 1 Create a Topology as shown below using two routers

Dynamic NAT Configuration

Step 2 After Configuring the topology ping from the internal network PC and the external router can detects the IP from which request is coming by using simple command as given below 

Dynamic NAT Configuration

 Router#debug ip icmp

we can see the result on external router after pinging from both the PCs

Dynamic NAT Configuration

Dynamic NAT Configuration

Step 3 Now lets hide our internal PC IP from the external router by using dynamic NAT

Dynamic NAT Configuration

Router(config)#ip access-list extended 101

Router(config-ext-nacl)#permit ip any any

Router(config-ext-nacl)#exit

Router(config)#ip nat pool sachtech 192.168.1.100 192.168.1.150 netmask 255.255.255.0

Router(config)#ip nat inside source list 101 pool sachtech

Router(config)#int fa 0/0

Router(config-if)#ip nat inside

Router(config-if)#exit

Router(config)#int se 0/1/0

Router(config-if)#ip nat outside

Step 4 Now lets check the output after pinging from internal PC to external router 

as we can see here internal ip is being converted to the NAT converted IPs .Thanks

Static NAT Configuration

Static NAT Configuration

In this topic we will learn Static NAT Configuration. NAT stands for network address translation. in static nat only one to one IP is being translated . internal private IP can be converted to  any external public IP.lets start our configuration.

Step 1 Create a topology in cisco packet tracer using two routers as given below 

Static NAT Configuration

Step 2 After configuring all your network just check the connectivity from any PC to the EXTERNAL router

Static NAT Configuration

Step 3 Now lets check How the EXTERNAL Router detects the internal IP of any PC which has ping request 

Static NAT Configuration

EXTERNALROUTER#debug IP icmp (by this command we can detect the external IP) after pinging from both the PCs we can check the result on EXTERNAL ROUTER  it detects the internal IP of the network 

Step 4 Now lets apply Static NAT commands on the internal router 

Router(config)#ip nat inside source static 10.0.0.2 192.168.1.100

Router(config)#int fa 0/0

Router(config-if)#ip nat inside

Router(config-if)#int se 0/1/0

Router(config-if)#ip nat outside

Static NAT Configuration

after applying this command lets ping once again from the PC to EXTERNAL ROUTER 

Static NAT Configuration

as we have translated on internal IP 10.0.0.2 to 192.168.1.100 so the EXTERNAL ROUTER detects as

Static NAT Configuration

and the another ip 10.0.0.3 is not being in the NAT table so that is being not converted. Thank You

 

 

How to install phpmyadmin in ubuntu

How to install phpmyadmin in ubuntu

Hello pal today we will learn how to install phpmyadmin in ubuntu any version .phpmyadmin is tool intended to handle the administration of MySQL over the Web.so without any delay lets start

Step 1 Open terminal in ubuntu and enter into sudo mode to execute the command to install Apache web server with which phpmyadmin will work 

~# apt-get install apache2

How to install phpmyadmin in ubuntu

Step 2 After the Apache web server has been successfully installed we will also install php  into our system 

~# apt-get install php7.2

How to install phpmyadmin in ubuntu

Step 3 Now after php and Apache web server has been installed we will install phpmyadmin service by using following commands

~# apt-get install phpmyadmin

How to install phpmyadmin in ubuntu

and once this service has been installed lets verify the service whether its working fine or not.

open any web browser preferably chrome and type in URL

http://localhost/phpmyadmin/

if this page comes up type username root and password root and its done. thanks

 

 

 

How to install android studio in ubuntu

How to install android studio in ubuntu

In this tutorial we will learn How to install android studio in  ubuntu. android studio is a platform which is used to develop android applications   so lets start the installation process.

Step 1 First we have to install JRE(java run time environment) and JDK(java development kit) before installing android studio.This can be installed via terminal in sudo mode 

# apt-get install default-jre & default-jdk

How to install android studio in ubuntu

Step 2 After installing JAVA JDK & JRE modules we will reconfirm the installed java and update the system by using commands below

# java -version

How to install android studio in ubuntu

Step 3 After we have successfully installed JAVA modules we will download android studio packages for the link given below

https://developer.android.com/studio/

How to install android studio in ubuntu

Step 4 After downloading the complete setup file will be in the zip format you have extract it as per your desired location you want .

How to install android studio in ubuntu

Step 5 After extracting the zip file right click on the extracted folder and select open in terminal 

How to install android studio in ubuntuHow to install android studio in ubuntu

Step 6 Enter into sudo mode and move to bin folder 

rahul@simran:~/Downloads/android-studio$ sudo -s
[sudo] password for rahul:
root@simran:~/Downloads/android-studio# cd bin
root@simran:~/Downloads/android-studio/bin# sh studio.sh

hit enter after last command and installation will begin 

How to install android studio in ubuntu

stay tuned for more thank you !!!!!!!!!

 

 

 

amazon ec2 windows

amazon ec2 windows

amazon ec2 windows in this topic we will learn how we can launch window instance on amazon web

server and access it on our local machine. sign into your existing AWS account and follow the

steps below

  1. on the first page click on the services

amazon ec2 windows

 

2. now click on the service and after that click on ec2

 

amazon ec2 windows

 

3.  on the next page click on the launch instance that is colored in blue color

amazon ec2 windows

4. on the next page we will get the options to selects the AMI (Amazon Machine Images)  here find

the window server 2012r2 and select it

amazon ec2 windows

5. on the next page we will be getting the detailed information about our instance here click on review and

launch instance

amazon ec2 windows

 

6. on the next page we will asked for final review here just click on the launch button

amazon ec2 windows

 

7. on the next page we will prompted for the creating a key pair which will be used to connect to this instance

after downloading we will be directed to the final instance page here just click on the instance id number that’s

it

amazon ec2 windows

select create a new key pair with a new name

amazon ec2 windowsV

 

download the key pair and click on the instance id

amazon ec2 windows

after clicking on the instance id we will be redirected to final instance page as shown below

amazon ec2 windows

 

now we have successfully launch the window server 2012r2 on  AWS . now how we can connect to this instance

from windows PC or Linux system is given in the following link

 

 

 

 

rocket chat server

rocket chat server

rocket chat server is an open source software which is used for create a chat rooms between clients.

this server is more fast and convenient as compare to another chat applications . it is easy to use

and can be used between many users no of clients that can be connected  is in very large number as

compared to any another chat software. increase productivity by sharing files , video calls and audio calls .

it can be used for creating groups or rooms . it is ultimate web chat platform

now lets follow the steps to install rocket chat server open terminal and type

 

sudo -s

sudo apt update && sudo apt upgrade

we need following dependencies

Node.js
MongoDB
curl
graphicsmagick

type this in terminal

rocket chat server

sudo apt-key adv –keyserver hkp://keyserver.ubuntu.com:80 –recv 7F0CEB10
echo “deb http://repo.mongodb.org/apt/ubuntu trusty/mongodb-org/3.0 multiverse” | sudo tee /etc/apt/sources.list.d/mongodb-org-3.0.list
sudo apt-get update
sudo apt-get install -y mongodb-org curl graphicsmagick

sudo apt-get install npm

rocket chat server

 

sudo apt-get install nodejs

sudo apt-get install build-essential

sudo npm install -g n

curl -L https://releases.rocket.chat/latest/download -o rocket.chat.tgz

tar zxvf rocket.chat.tgz

mv bundle Rocket.Chat
cd Rocket.Chat/programs/server
npm install
cd ../..

export ROOT_URL=http://sachtech.com:3000/
export MONGO_URL=mongodb://localhost:27017/rocketchat
export PORT=3000

node main.js

 

 

 

 

how to set static IP in Ubuntu

how to set static IP in Ubuntu

 

how to set static IP in Ubuntu

in this tutorial we will be learning how we can set up static IP in Ubuntu . static IP are basically assigned

to allocate fix IP to any systems that act as a servers like ftp server , web server etc. lets check how we can

check our IP in Ubuntu. type in terminal

~# ifconfig

 

 

enp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.0.104 net mask 255.255.255.0 broadcast 192.168.0.255
inet6 fe80::5635:7aaa:5280:5127 prefixlen 64 scopeid 0x20<link>
ether 38:2c:4a:b2:0a:1e txqueuelen 1000 (Ethernet)
RX packets 164533 bytes 137858117 (137.8 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 105117 bytes 22753193 (22.7 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOP BACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10<host>
loop txqueuelen 1000 (Local Loopback)
RX packets 8139 bytes 1704840 (1.7 MB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 8139 bytes 1704840 (1.7 MB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

the text labled red in the IP address allocated to the system now lets change this by typing

 

nano /etc/network/interfaces

 

 

add these lines in the file

auto eth0
iface eth0 inet static
address 10.253.0.50
netmask 255.255.255.0
network 10.253.0.0
gateway 10.253.0.1
dns-nameservers 8.8.8.8

 

now save this file by entering Ctrl+o enter and Ctrl +x enter

and reboot we will be seeing our static IP address over there .

 

 

 

 

 

 

 

linux dhcp server

linux dhcp server

linux dhcp server acts as a server for providing ip address to the client systems.

this work on the DORA process. D is discover O is offer R is request A is

acknowledgement. with this server user do not require to set static ip to his

system as this server provides automatic assignment of IP  address to the

system. lets see  how we can configure DHCP server in ubuntu

linux dhcp server

after update command we will install dhcp server with below written commands

linux dhcp server

after complete installation of dhcp server we will configure our dhcp server

configuration file

 

linux dhcp server

#
# Sample configuration file for ISC dhcpd for Debian
#
# Attention: If /etc/ltsp/dhcpd.conf exists, that will be used as
# configuration file instead of this file.
#
#

# The ddns-updates-style parameter controls whether or not the server will
# attempt to do a DNS update when a lease is confirmed. We default to the
# behavior of the version 2 packages (‘none’, since DHCP v2 didn’t
# have support for DDNS.)
ddns-update-style none;

# option definitions common to all supported networks…
option domain-name “example.org”;
option domain-name-servers ns1.example.org, ns2.example.org;

default-lease-time 600;
max-lease-time 7200;

# If this DHCP server is the official DHCP server for the local
# network, the authoritative directive should be uncommented.
#authoritative;

# Use this to send dhcp log messages to a different log file (you also
# have to hack syslog.conf to complete the redirection).
log-facility local7;

# No service will be given on this subnet, but declaring it helps the
# DHCP server to understand the network topology.

subnet 100.0.0.0 netmask 255.0.0.0 {
range 100.0.0.100 100.0.0.200;
option router 100.0.0.1;
option broadcast-address 100.255.255.255;
}

# This is a very basic subnet declaration.

#subnet 10.254.239.0 netmask 255.255.255.224 {
# range 10.254.239.10 10.254.239.20;
# option routers rtr-239-0-1.example.org, rtr-239-0-2.example.org;
#}

# This declaration allows BOOTP clients to get dynamic addresses,
# which we don’t really recommend.

#subnet 10.254.239.32 netmask 255.255.255.224 {
# range dynamic-bootp 10.254.239.40 10.254.239.60;
# option broadcast-address 10.254.239.31;
# option routers rtr-239-32-1.example.org;
#}

# A slightly different configuration for an internal subnet.
#subnet 10.5.5.0 netmask 255.255.255.224 {
# range 10.5.5.26 10.5.5.30;
# option domain-name-servers ns1.internal.example.org;
# option domain-name “internal.example.org”;
# option routers 10.5.5.1;
# option broadcast-address 10.5.5.31;
# default-lease-time 600;
# max-lease-time 7200;
#}

# Hosts which require special configuration options can be listed in
# host statements. If no address is specified, the address will be
# allocated dynamically (if possible), but the host-specific information
# will still come from the host declaration.

#host passacaglia {
# hardware ethernet 0:0:c0:5d:bd:95;
# filename “vmunix.passacaglia”;
# server-name “toccata.fugue.com”;
#}

# Fixed IP addresses can also be specified for hosts. These addresses
# should not also be listed as being available for dynamic assignment.
# Hosts for which fixed IP addresses have been specified can boot using
# BOOTP or DHCP. Hosts for which no fixed address is specified can only
# be booted with DHCP, unless there is an address range on the subnet
# to which a BOOTP client is connected which has the dynamic-bootp flag
# set.
#host fantasia {
# hardware ethernet 08:00:07:26:c0:a5;
# fixed-address fantasia.fugue.com;
#}

# You can declare a class of clients and then do address allocation
# based on that. The example below shows a case where all clients
# in a certain class get addresses on the 10.17.224/24 subnet, and all
# other clients get addresses on the 10.0.29/24 subnet.

#class “foo” {
# match if substring (option vendor-class-identifier, 0, 4) = “SUNW”;
#}

#shared-network 224-29 {
# subnet 10.17.224.0 netmask 255.255.255.0 {
# option routers rtr-224.example.org;
# }
# subnet 10.0.29.0 netmask 255.255.255.0 {
# option routers rtr-29.example.org;
# }
# pool {
# allow members of “foo”;
# range 10.17.224.10 10.17.224.250;
# }
# pool {
# deny members of “foo”;
# range 10.0.29.10 10.0.29.230;
# }
#}

just add the following lines (marked red above) in the configuration file and restart

mail server in linux

mail server in linux

mail server in linux is a server which acts as a client to flow messages from one

user to another. today we will learn how we can create mail server in ubuntu .

we will be using ubuntu 14.04 for the server configuration .the steps mentioned

are for all the versions of the ubuntu after 14.04. step by step configuration as below, there are some pre-requirements for the mail server .

1)apache server

2)postfix

3)dovecot

4)squirrel mail server

Inspiron-N5050:~# apt-get update

mail server in linux

and we will install apache server

Inspiron-N5050:~# apt-get install apache2

mail server in linux

now we will be install postfix server

Inspiron-N5050:~# apt-get install postfix

mail server in linux

 

Inspiron-N5050:~# apt-get install dovecot-imapd dovecot-pop3d

mail server in linux

 

Inspiron-N5050:~# apt-get install squirrelmail

mail server in linux

Inspiron-N5050:~# squirrelmail-configure

mail server in linux

than select 2

mail server in linux

than press r and select 4

mail server in linux

here select 11

mail server in linux

and than we will restart the dovecot and imap services

mail server in linux

now next

Inspiron-N5050:~# cp /etc/squirrelmail/apache.conf /etc/apache2/sites-available/squirrelmail.conf

and next

now restarting squirrelmail site

Inspiron-N5050:~# a2ensite squirrelmail.conf

mail server in linux

now lets check on our browser

mail server in linux

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

aws tutorial

aws tutorial

aws tutorial here we will discuss how to launch instance  in aws. in our last aws topic we discussed how to create

aws account now in this topic we will discuss how to launch first instance . for that first we will login into our account and than

here first click on  services

aws tutorial

and than click on the ec2 under compute and than

aws tutorial

and now click on the launch instance

aws tutorial

on this page we will select the free tier eligible only as we are using the free trial account.and lets launch the window server 2012r2 server standard edition.

aws tutorial

and on clicking we will be redirected  to the next page

aws tutorial

and here we will select the review and launch option and create a key pair for connecting to this instance

aws tutorial

and after that we have to download the key pair and click on launch instance

aws tutorial

and this is the final stage our instance is launched

 

 

 

 

 

 

VTP

vtp

vtp stands for vlan trunking protocol. this protocol was developed by cisco .it carries the vlan

(virtual local area network) database from one switch to another in same domain. with vtp we can

synchronize same vlan id and vlan name that are running in the same domain. these are the layer 2 protocols.

this protocol is basically used to reduce the need of configuring vlan on every switch. lets suppose we have 100

switches in our network in that case a administrator has to manually configure vlan on every switch, and that

would be very difficult and would be so much time consuming. while configuring this protocol we have to keep

one thing in  mind that one switch would be acting like  a switch and all the another will be acting as a client.

lets move to our lab configuration of the vtp and understand it better

lab configuration

vtp

here we will be using 4 switches  and we will be using one of them as a server switch and all other as a client switches.

vtp

server>en

server#conf t

Enter configuration commands, one per line. End with CNTL/Z.

server(config)#hostname server

server(config)#vtp domain sachtech.com

Domain name already set to sachtech.com.

server(config)#vtp password hello

Setting device VLAN database password to hello

now lets create some vlan over this server switch vtp

server(config)#vlan 10

server(config-vlan)#name data

server(config-vlan)#exit

server(config)#vlan 20

server(config-vlan)#name voice

server(config-vlan)#exit

server(config)#vlan 30

server(config-vlan)#name finance

server(config-vlan)#exit

now we can also check our vlan database by typing vtp

server(config)#do sh vlan

and as we can see in the above image we can see our newly created vlans. now next

vtp

server(config)#int fa 0/1

server(config-if)#switchport mode trunk

server(config-if)#

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down

%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

we have to put our interface which is connecting to the another switch into trunk mode as then

only it can be  able to transfer vlan over the LAN. now configuring the another switches

vtp

as we can see here no vlan has been created in this switch now switching the domain and thereafter we will see the results

Switch(config)#vtp mode client

Setting device to VTP CLIENT mode.

Switch(config)#vtp domain sachtech.com

Domain name already set to sachtech.com.

Switch(config)#vtp password hello

Setting device VLAN database password to hello

vtp

now lets check the database

vtp

as we see in above image all the three vlans which we have created in the server switch are being present in the client switch also . therefore in this way we can use vtp protocols to flow vlan database between different switches which are on same domain

 

 

 

 

 

 

Please wait...

Subscribe to our newsletter

Want to be notified when our article is published? Enter your email address and name below to be the first to know.